Endpoint

10/19/2018
04:00 PM
50%
50%

Google Patch to Block Spectre Slowdown in Windows 10

Microsoft will incorporate Google's Retpoline patch to prevent Spectre Variant 2 from slowing down its operating system.

Microsoft plans to include the Retpoline patch, a fix developed by Google, in an upcoming version of Windows 10 to prevent slowdown caused by Spectre Variant 2, ZDNet reports.

Spectre Variant 2, a speculative execution side-channel attack, has caused much industry concern about its significant effect on operating system performance. While Intel issued fixes addressing Variant 2, a "branch target injection" bug, it also admits the mitigation's impact on performance varies based on the platform configuration, mitigation technique, and specific workload.

Google reports its Retpoline patch, which is software-based and designed to limit speculative execution activity, has a "negligible impact on performance" based on testing. It has already been used by Oracle in Oracle Linux 6 and 7, and by Linux distributions Red Hat and SUSE, the report says.

Now the patch is making its way to Windows 10. Microsoft kernel engineers report Retpoline will be built into 19H1, an upcoming version of the operating system slated to roll out next year.

Read more details here.

 

Black Hat Europe returns to London Dec 3-6 2018  with hands-on technical Trainings, cutting-edge Briefings, Arsenal open-source tool demonstrations, top-tier security solutions and service providers in the Business Hall. Click for information on the conference and to register.

Dark Reading's Quick Hits delivers a brief synopsis and summary of the significance of breaking news events. For more information from the original source of the news item, please follow the link provided in this article. View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
techate
50%
50%
techate,
User Rank: Apprentice
11/5/2018 | 2:59:12 PM
Re: Google Patch
Window 10 is very useful OS which is very useful for fast internet but google patch is the cause of block specter which we get a slowdown in the window. You have provided good tips to deal with this issue or windows error 0x8024200b here you find more solution for this issue
symphonygarner
100%
0%
symphonygarner,
User Rank: Apprentice
11/1/2018 | 6:10:40 AM
Google Patch
This patch really covered some of the errors that have been making our life hell for a long time. I have to make sure that the deal will make sure to get things done easily in the win 10. Windows 10 Recovery Media center was behaving hastily and end up being in the loading loop.
Microsoft President: Governments Must Cooperate on Cybersecurity
Kelly Sheridan, Staff Editor, Dark Reading,  11/8/2018
5 Reasons Why Threat Intelligence Doesn't Work
Jonathan Zhang, CEO/Founder of WhoisXML API and TIP,  11/7/2018
Why Password Management and Security Strategies Fall Short
Steve Zurier, Freelance Writer,  11/7/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Flash Poll
Online Malware and Threats: A Profile of Today's Security Posture
Online Malware and Threats: A Profile of Today's Security Posture
This report offers insight on how security professionals plan to invest in cybersecurity, and how they are prioritizing their resources. Find out what your peers have planned today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-6260
PUBLISHED: 2018-11-13
NVIDIA graphics driver contains a vulnerability that may allow access to application data processed on the GPU through a side channel exposed by the GPU performance counters. Local user access is required. This is not a network or remote attack vector.
CVE-2018-16850
PUBLISHED: 2018-11-13
postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.
CVE-2018-17187
PUBLISHED: 2018-11-13
The Apache Qpid Proton-J transport includes an optional wrapper layer to perform TLS, enabled by use of the 'transport.ssl(...)' methods. Unless a verification mode was explicitly configured, client and server modes previously defaulted as documented to not verifying a peer certificate, with options...
CVE-2018-1792
PUBLISHED: 2018-11-13
IBM WebSphere MQ 8.0.0.0 through 8.0.0.10, 9.0.0.0 through 9.0.0.5, 9.0.1 through 9.0.5, and 9.1.0.0 could allow a local user to inject code that could be executed with root privileges. IBM X-Force ID: 148947.
CVE-2018-1808
PUBLISHED: 2018-11-13
IBM WebSphere Commerce 9.0.0.0 through 9.0.0.6 could allow some server-side code injection due to inadequate input control. IBM X-Force ID: 149828.