Endpoint //

Privacy

Encryption is Necessary, Tools and Tips Make It Easier

In the InteropITX conference, a speaker provided tips, tools, and incentives for moving to pervasive encryption in the enterprise.

InteropITX 2018 — Las Vegas — Encryption is critical and encryption can be complicated. Fortunately, there are tips, techniques, and information tools that can help reduce the difficulty and make proper encryption more achievable and affordable for most organizations. That was the message Ali Pabrai was preaching from the platform in an early morning session on Thursday.

Pabrai, CEO of security consulting firm ecfirstm, began the session by running through some of the critical security incidents that have forced companies to the conclusion that encryption is not merely an option for enterprise security — it's a necessity.

October 21, 2016 was one of the dates Pabrai recalled because it was the day on which the Mirai botnet activated and went on the offensive against DNS provider Dyn. At the time the most powerful DDoS attack on record, Pabrai said that Mirai will be the model for more powerful attacks to come. Avoiding having company computers and IoT devices become part of an attacker's weaponized network is just one of the reasons he gave for encrypting as much data (and data traffic) as possible. Many of the other reasons involve regulations.

May 25, 2018 is the day that GDPR begins to be enforced. It has a lot to say about protecting data and notifying customers if unprotected data is breached. It's also not the first regulation with those requirements. "HITECH has been with us since 2010," said Pabrai, noting that the Health Information Technology for Economic and Clinical Health (HITECH) Act defines "unprotected data" and specifies actions to be taken when it is breached.

Beyond the various regulations regarding encryption and data, there are frameworks and tools that help organizations understand how to go about protecting data both at rest and in transit.

"You can't be in cybersecurity without being literate in the NIST framework," Pabrai said, noting that, on April 16, NIST introduced the Cybersecurity Framework 1.1. The framework is quite prescriptive regarding best practices for building encryption into an enterprise process. That makes it and PCI DSS — another highly prescriptive standard — especially valuable resources for enterprise data security professionals.

In addition to the large frameworks and regulations, Pabrai argued in favor of a low-tech tool and basic strategy for dealing with encryption.

The low-tech tool is a spreadsheet listing every possible enterprise attack surface (data base, mobile devices, IoT, etc.) and whether the state of encryption is yes, no, or unknown. He said  that this tool allows him to understand the basic security stance of an organization in a matter of minutes during the initial encounter.

The basic strategy is taking the argument for wide-spread encryption — that it dramatically reduces risk exposure — to the executive committee with questions about why they would want to take this critical step.

There's no doubt that encryption requires investment, Pabrai said, but compared to the financial risk of unprotected data it is an investment that makes sense for practically every organization.

Related Content:

Curtis Franklin Jr. is Senior Editor at Dark Reading. In this role he focuses on product and technology coverage for the publication. In addition he works on audio and video programming for Dark Reading and contributes to activities at Interop ITX, Black Hat, INsecurity, and ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
New Free Tool Scans for Chrome Extension Safety
Dark Reading Staff 2/21/2019
Making the Case for a Cybersecurity Moon Shot
Adam Shostack, Consultant, Entrepreneur, Technologist, Game Designer,  2/19/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
5 Emerging Cyber Threats to Watch for in 2019
Online attackers are constantly developing new, innovative ways to break into the enterprise. This Dark Reading Tech Digest gives an in-depth look at five emerging attack trends and exploits your security team should look out for, along with helpful recommendations on how you can prevent your organization from falling victim.
Flash Poll
New Best Practices for Secure App Development
New Best Practices for Secure App Development
The transition from DevOps to SecDevOps is combining with the move toward cloud computing to create new challenges - and new opportunities - for the information security team. Download this report, to learn about the new best practices for secure application development.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-6485
PUBLISHED: 2019-02-22
Citrix NetScaler Gateway 12.1 before build 50.31, 12.0 before build 60.9, 11.1 before build 60.14, 11.0 before build 72.17, and 10.5 before build 69.5 and Application Delivery Controller (ADC) 12.1 before build 50.31, 12.0 before build 60.9, 11.1 before build 60.14, 11.0 before build 72.17, and 10.5...
CVE-2019-9020
PUBLISHED: 2019-02-22
An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. Invalid input to the function xmlrpc_decode() can lead to an invalid memory access (heap out of bounds read or read after free). This is related to xml_elem_parse_buf in ext/xmlrpc/libxmlrpc...
CVE-2019-9021
PUBLISHED: 2019-02-22
An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A heap-based buffer over-read in PHAR reading functions in the PHAR extension may allow an attacker to read allocated or unallocated memory past the actual data when trying to parse the file...
CVE-2019-9022
PUBLISHED: 2019-02-22
An issue was discovered in PHP 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.2. dns_get_record misparses a DNS response, which can allow a hostile DNS server to cause PHP to misuse memcpy, leading to read operations going past the buffer allocated for DNS data. This affects php_parser...
CVE-2019-9023
PUBLISHED: 2019-02-22
An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A number of heap-based buffer over-read instances are present in mbstring regular expression functions when supplied with invalid multibyte data. These occur in ext/mbstring/oniguruma/regcom...