Cloud

Kubernetes Vulnerability Hits Top of Severity Scale

The security issue strikes at some of the basic reasons for the rising popularity of containers as an architecture and Kubernetes as an orchestration mechanism.

The first major security vulnerability – 9.8 out of a possible 10 – in Kubernetes was disclosed earlier this week.  

The vulnerability (CVE-2018-1002105) allows for privilege escalation and can be accessed by both authorized and unauthorized users. For authorized users with "attach," "exec," or "portforward" privileges, escalating those to admin privileges that allow any process to be executed is trivial.

And for anyone at all, an API used in three specific modules will allow a query that returns values that can be used to raise privileges to admin level for any API deployed on the container cluster.

"Depending on the organization's architecture, this vulnerability is like leaving the door open to the enterprise's entire cloud environment," said Nick Morris, managing principal of cyber engineering at Coalfire. "The security risks are made even more challenging in that a compromise might not be detectable as it obfuscates the detection capabilities."

One of the factors that makes this vulnerability so severe is its scope. "This vulnerability has existed in every version of Kubernetes since v1.0," said Wei Lien Dang, vice president of products at StackRox. "But Kubernetes is complex software with a large codebase, which can lead, to some extent, to various security issues."

The security issue strikes at some of the basic reasons for the rising popularity of containers as an architecture and Kubernetes as an orchestration mechanism. "What makes Kubernetes great is its fundamental speed, orchestration, automation, and scale. All of those qualities become an instant detriment when a security issue arises as they rapidly extend the reach of the attack," said Sumo Logic CSO George Gerchow. 

Fortunately for Kubernetes users, two fixes are available for the vulnerability. The first is to update any deployed Kubernetes instances to versions 1.10.11, 1.11.5, 1.12.3 and 1.13.0-rc1. Each has been patched to remediate the vulnerability. Major cloud service providers also have announced that they have patched their instances, and the question is appropriate for any Kubernetes provider.

The Kubernetes vulnerability may provide yet another opportunity for organizations to examine their patching and updating policies. "Companies routinely fail to install updates to known vulnerabilities," Dang said. "So how many are likely to drag their heels and be exploited by this as a result of inaction? It depends on how they're deploying and using Kubernetes.".

For companies that are unable to update to one of the patched versions of Kubernetes, mitigation steps have been published that will remove the vulnerability, though developers warn they may also disrupt existing operations for some users. According to Gerchow, protection from this, and similar, vulnerabilities means closer relations between development and security teams, with DevSecOps a legitimate way to improve communication and cooperation. "Most organizations lack visibility into the proper security and configuration of not just its containers but the CI/CD pipeline as a whole," he says.

Related Content:

 

Curtis Franklin Jr. is Senior Editor at Dark Reading. In this role he focuses on product and technology coverage for the publication. In addition he works on audio and video programming for Dark Reading and contributes to activities at Interop ITX, Black Hat, INsecurity, and ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
kamalshah
50%
50%
kamalshah,
User Rank: Apprentice
1/2/2019 | 8:09:29 PM
The rise of DevSecOps
This vulnerability highlights the urgent need for greater collaboration between DevOps and Security, and the growing importance of DevSecOps.
Crowdsourced vs. Traditional Pen Testing
Alex Haynes, Chief Information Security Officer, CDL,  3/19/2019
BEC Scammer Pleads Guilty
Dark Reading Staff 3/20/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: This comment is waiting for review by our moderators.
Current Issue
5 Emerging Cyber Threats to Watch for in 2019
Online attackers are constantly developing new, innovative ways to break into the enterprise. This Dark Reading Tech Digest gives an in-depth look at five emerging attack trends and exploits your security team should look out for, along with helpful recommendations on how you can prevent your organization from falling victim.
Flash Poll
The State of Cyber Security Incident Response
The State of Cyber Security Incident Response
Organizations are responding to new threats with new processes for detecting and mitigating them. Here's a look at how the discipline of incident response is evolving.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-18913
PUBLISHED: 2019-03-21
Opera before 57.0.3098.106 is vulnerable to a DLL Search Order hijacking attack where an attacker can send a ZIP archive composed of an HTML page along with a malicious DLL to the target. Once the document is opened, it may allow the attacker to take full control of the system from any location with...
CVE-2018-20031
PUBLISHED: 2019-03-21
A Denial of Service vulnerability related to preemptive item deletion in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor ...
CVE-2018-20032
PUBLISHED: 2019-03-21
A Denial of Service vulnerability related to message decoding in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon t...
CVE-2018-20034
PUBLISHED: 2019-03-21
A Denial of Service vulnerability related to adding an item to a list in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor ...
CVE-2019-3855
PUBLISHED: 2019-03-21
An integer overflow flaw which could lead to an out of bounds write was discovered in libssh2 before 1.8.1 in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to execute code on the client system when a user connects to the server.