Vulnerabilities / Threats

2/7/2018
02:18 PM
50%
50%

Cisco Issues New Patch for Critical ASA Vulnerability

Cisco engineers discover that the flaw in Adaptive Security Appliance devices is worse than they initially understood.

One week after network administrators had begun deploying patches for a critical (CVSS 10.0) vulnerability in Cisco Adaptive Security Appliance (ASA) devices, Cisco released a second advisory, stating that the patch would not fix the whole problem.

Cisco released an updated patch Monday, and although there are no reports of active exploits, they urge customers to deploy the fix right away.

The vulnerability, CVE-2018-0101, is a remote code execution flaw in the ASA software XML parser that requires no authentication to exploit. It was originally fixed Jan. 29. The updated patch was necessary, because after further investigation, Cisco engineers discovered that the vuln affected more features and had more attack vectors than they initially believed.

"In addition," Cisco principal engineer Omar Santos wrote in the Cisco Product Security Incident Response Team blog, "it was also found that the original list of fixed releases published in the security advisory were later found to be vulnerable to additional denial of service conditions."  

For more information, see here

Dark Reading's Quick Hits delivers a brief synopsis and summary of the significance of breaking news events. For more information from the original source of the news item, please follow the link provided in this article. View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
White House Cybersecurity Strategy at a Crossroads
Kelly Jackson Higgins, Executive Editor at Dark Reading,  7/17/2018
Lessons from My Strange Journey into InfoSec
Lysa Myers, Security Researcher, ESET,  7/12/2018
What's Cooking With Caleb Sima
Kelly Jackson Higgins, Executive Editor at Dark Reading,  7/12/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2016-9574
PUBLISHED: 2018-07-19
nss before version 3.30 is vulnerable to a remote denial of service during the session handshake when using SessionTicket extension and ECDHE-ECDSA.
CVE-2017-2673
PUBLISHED: 2018-07-19
An authorization-check flaw was discovered in federation configurations of the OpenStack Identity service (keystone). An authenticated federated user could request permissions to a project and unintentionally be granted all related roles including administrative roles.
CVE-2017-7481
PUBLISHED: 2018-07-19
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templati...
CVE-2018-12911
PUBLISHED: 2018-07-19
WebKitGTK+ 2.20.3 has an off-by-one error, with a resultant out-of-bounds write, in the get_simple_globs functions in ThirdParty/xdgmime/src/xdgmimecache.c and ThirdParty/xdgmime/src/xdgmimeglob.c.
CVE-2018-14404
PUBLISHED: 2018-07-19
A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulne...