Vulnerabilities / Threats

9/26/2018
07:00 PM
Connect Directly
Twitter
LinkedIn
RSS
E-Mail
50%
50%

Critical Linux Kernel Flaw Gives Root Access to Attackers

All versions of Red Hat Enterprise Linux, CentOS vulnerable to 'Mutagen Astronomy' flaw, according to Qualys.

Multiple Linux distributions including all current versions of Red Hat Enterprise Linux and CentOS contain a newly discovered bug that gives attackers a way to obtain full root access on vulnerable systems.

The integer overflow flaw (CVE-2018-14634)exists in a critical Linux kernel function for memory management and allows attackers with unprivileged local access to a system to escalate their privileges. Researchers from security vendor Qualys discovered the issue and have developed a proof of concept exploit.

A patch for the flaw, which Qualys has dubbed "Mutagen Astronomy," is available, and most Linux distributions have already "backported" the patch for older versions of their kernels. But Red Hat Linux Enterprise, CentOS, and the Debian 8, or the "oldstable" version, are yet not patched, Qualys said in a security advisory this week.

In a statement, Red Hat said the issue impacts Red Hat Enterprise Linux 6, 7, and Red Hat Enterprise MRG 2. But versions of the Linux kernel shipped with Red Hat Linux 5 are not impacted, and systems with less than 32GB of memory are also very unlikely to be impacted by the vulnerability, "as they do not have a large enough address space to exploit this flaw," Red Hat said.

The vulnerability has been assigned a CVSS base score of 7.8, but Red Hat has assessed it as having high impact on confidentiality, integrity, and availability.  The vendor described the vulnerability as being exploitable with no user-interaction needed and involving low attack complexity.

Anagram

Jimmy Graham, director of product management and vulnerability management at Qualys, says the name "Mutagen Astronomy" is an anagram of "Too Many Arguments," which is the fundamental vulnerability being exploited.

The flaw is another reminder of the importance of the need for layered defenses, he says. Often attackers who exploit a remote vulnerability—such as a Web-application exploit, for instance—only gain unprivileged access on the vulnerable system.

So cybercriminals typically combine the use of lower-severity flaws with more severe ones like the Mutagen Astronomy flaw to create a very functional attack, Graham explains. "This type of vulnerability is often used in conjunction with other kinds of attacks," he says. "If an attacker has an existing foothold on a system but is unable to escalate to root, they may utilize a vulnerability like this to fully compromise the system."

That is why proper vulnerability and patch management is crucial, and should not be limited only to remediation of "critical" vulnerabilities, he adds.

Linux developer Kees Cook developed the patch for the flaw based on previous work by grsecurity, and most Linux distrbutions have backported it to their long-term-supported kernels. A backported patch is a patch that has been developed for the current mainline Linux kernel but can be applied to older, or long-term-supported (LTS) kernels, Graham says.

It's up to each Linux provider to decide if a patch is important enough for them to backport, and whether there's a likelihood of the patch harming the stability of their older LTS kernels.

"In this particular case, most distributions backported this patch, but Red Hat Enterprise Linux and CentOS did not," Graham says. All versions of these distributions are affected - even in their default and minimal installations, he notes.

Red Hat's advisory includes advice on how organizations can mitigate the vulnerability. The company will address the issue in updates for Red Hat Enterprise Linux 6, 7, and other affected versions.

Related Content:

 

Black Hat Europe returns to London Dec 3-6 2018  with hands-on technical Trainings, cutting-edge Briefings, Arsenal open-source tool demonstrations, top-tier security solutions and service providers in the Business Hall. Click for information on the conference and to register.

Jai Vijayan is a seasoned technology reporter with over 20 years of experience in IT trade journalism. He was most recently a Senior Editor at Computerworld, where he covered information security and data privacy issues for the publication. Over the course of his 20-year ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
6 Security Trends for 2018/2019
Curtis Franklin Jr., Senior Editor at Dark Reading,  10/15/2018
6 Reasons Why Employees Violate Security Policies
Ericka Chickowski, Contributing Writer, Dark Reading,  10/16/2018
Getting Up to Speed with "Always-On SSL"
Tim Callan, Senior Fellow, Comodo CA,  10/18/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Latest Comment: Too funny!
Current Issue
Flash Poll
The Risk Management Struggle
The Risk Management Struggle
The majority of organizations are struggling to implement a risk-based approach to security even though risk reduction has become the primary metric for measuring the effectiveness of enterprise security strategies. Read the report and get more details today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-10839
PUBLISHED: 2018-10-16
Qemu emulator <= 3.0.0 built with the NE2000 NIC emulation support is vulnerable to an integer overflow, which could lead to buffer overflow issue. It could occur when receiving packets over the network. A user inside guest could use this flaw to crash the Qemu process resulting in DoS.
CVE-2018-13399
PUBLISHED: 2018-10-16
The Microsoft Windows Installer for Atlassian Fisheye and Crucible before version 4.6.1 allows local attackers to escalate privileges because of weak permissions on the installation directory.
CVE-2018-18381
PUBLISHED: 2018-10-16
Z-BlogPHP 1.5.2.1935 (Zero) has a stored XSS Vulnerability in zb_system/function/c_system_admin.php via the Content-Type header during the uploading of image attachments.
CVE-2018-18382
PUBLISHED: 2018-10-16
Advanced HRM 1.6 allows Remote Code Execution via PHP code in a .php file to the user/update-user-avatar URI, which can be accessed through an "Update Profile" "Change Picture" (aka user/edit-profile) action.
CVE-2018-18374
PUBLISHED: 2018-10-16
XSS exists in the MetInfo 6.1.2 admin/index.php page via the anyid parameter.