Vulnerabilities / Threats //

Vulnerability Management

4/4/2018
12:20 PM
50%
50%

New DARPA Contract Looks to Avoid Another 'Meltdown'

A new DARPA contract with Tortuga Logic intends to field chip emulation systems to test security before processors hit manufacturing.

The Defense Advanced Research Projects Agency (DARPA) has signed a contract with Tortuga Logic to develop hardware that integrates Tortuga Logic’s hardware security models with commercial emulation platforms to fully test an entire chip design running a full software stack.

As part of the contract, participants of the DARPA System Security Integrated Through Hardware and Firmware (SSITH) program will have early access to the emulation platforms that come from the research. The goal of the SSITH program is to develop hardware that is inherently more secure from the design process forward.

Tortuga Logic will build the emulation system on their two software suites, Prospect and Unison. The project will use the Palladium platform from Cadence Design Systems for the emulation component and will utilize the RISC-V processor architecture and sample design for initial prototyping and testing.

Avoiding a repeat of the Spectre and Meltdown vulnerabilities by helping implement a secure development lifecycle is a key goal of the project. The Meltdown and Spectre and related vulnerabilities affecting Intel, ARM, and AMD chips are examples of hardware security flaws that are exploited once chips are in the wild.

For more, read here and here.

Interop ITX 2018

Join Dark Reading LIVE for a two-day Cybersecurity Crash Course at Interop ITX. Learn from the industry’s most knowledgeable IT security experts. Check out the agenda here. Register with Promo Code DR200 and save $200.

Dark Reading's Quick Hits delivers a brief synopsis and summary of the significance of breaking news events. For more information from the original source of the news item, please follow the link provided in this article. View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
White House Cybersecurity Strategy at a Crossroads
Kelly Jackson Higgins, Executive Editor at Dark Reading,  7/17/2018
The Fundamental Flaw in Security Awareness Programs
Ira Winkler, CISSP, President, Secure Mentem,  7/19/2018
Number of Retailers Impacted by Breaches Doubles
Ericka Chickowski, Contributing Writer, Dark Reading,  7/19/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: This comment is waiting for review by our moderators.
Current Issue
Flash Poll
The State of Ransomware
The State of Ransomware
Ransomware has become one of the most prevalent new cybersecurity threats faced by today's enterprises. This new report from Dark Reading includes feedback from IT and IT security professionals about their organization's ransomware experiences, defense plans, and malware challenges. Find out what they had to say!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-14492
PUBLISHED: 2018-07-21
Tenda AC7 through V15.03.06.44_CN, AC9 through V15.03.05.19(6318)_CN, and AC10 through V15.03.06.23_CN devices have a Stack-based Buffer Overflow via a long limitSpeed or limitSpeedup parameter to an unspecified /goform URI.
CVE-2018-3770
PUBLISHED: 2018-07-20
A path traversal exists in markdown-pdf version <9.0.0 that allows a user to insert a malicious html code that can result in reading the local files.
CVE-2018-3771
PUBLISHED: 2018-07-20
An XSS in statics-server <= 0.0.9 can be used via injected iframe in the filename when statics-server displays directory index in the browser.
CVE-2018-5065
PUBLISHED: 2018-07-20
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have a Use-after-free vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.
CVE-2018-5066
PUBLISHED: 2018-07-20
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have an Out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.