Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Threat Intelligence

6/5/2019
12:15 PM
50%
50%

NSA Issues Advisory for 'BlueKeep' Vulnerability

The National Security Agency joins Microsoft in urging Windows admins to patch 'wormable' bug CVE-2019-0708.

The National Security Agency has issued a release and advisory pushing Microsoft Windows administrators to patch "BlueKeep" (CVE-2019-0708), a critical remote code execution bug in Remote Desktop Services (RDS) on supported and unsupported versions of Windows.

BlueKeep affects Windows 7, Server 2008, Server 2008 R2, Vista, XP, and Server 2003. When it patched the vulnerability earlier this month, Microsoft also released fixes for out-of-support versions of Windows. In a blog post published this week, company officials said they are "confident" an exploit exists for the bug; research shows 1 million devices are still vulnerable.

NSA officials echo Microsoft's concern that BlueKeep could be "wormable" if exploited. The vulnerability is pre-authentication, requires no user interaction, and can spread across machines in the same way WannaCry did when it caused global damage back in 2017.

"It is likely only a matter of time before remote exploitation code is widely available for this vulnerability," NSA officials wrote in a news release. "NSA is concerned that malicious cyber actors will use the vulnerability in ransomware and exploit kits containing other known exploits, increasing capabilities against other unpatched systems."

In its advisory, the NSA provides additional measures businesses can take as they patch and upgrade larger networks. Officials suggest blocking TCP Port 3389 at their firewalls; this port is used by RDP and can block attempts to establish a connection. They also advise enabling Network Level Authentication (NLA), which will require attackers to authenticate to RDS to exploit BlueKeep. Finally, they recommend disabling RDS if it's not required for employees.

Read the full NSA advisory here.

Dark Reading's Quick Hits delivers a brief synopsis and summary of the significance of breaking news events. For more information from the original source of the news item, please follow the link provided in this article. View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
For Cybersecurity to Be Proactive, Terrains Must Be Mapped
Craig Harber, Chief Technology Officer at Fidelis Cybersecurity,  10/8/2019
A Realistic Threat Model for the Masses
Lysa Myers, Security Researcher, ESET,  10/9/2019
USB Drive Security Still Lags
Dark Reading Staff 10/9/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
7 Threats & Disruptive Forces Changing the Face of Cybersecurity
This Dark Reading Tech Digest gives an in-depth look at the biggest emerging threats and disruptive forces that are changing the face of cybersecurity today.
Flash Poll
2019 Online Malware and Threats
2019 Online Malware and Threats
As cyberattacks become more frequent and more sophisticated, enterprise security teams are under unprecedented pressure to respond. Is your organization ready?
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-17593
PUBLISHED: 2019-10-14
JIZHICMS 1.5.1 allows admin.php/Admin/adminadd.html CSRF to add an administrator.
CVE-2019-17594
PUBLISHED: 2019-10-14
There is a heap-based buffer over-read in the _nc_find_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.
CVE-2019-17595
PUBLISHED: 2019-10-14
There is a heap-based buffer over-read in the fmt_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.
CVE-2019-14823
PUBLISHED: 2019-10-14
A flaw was found in the "Leaf and Chain" OCSP policy implementation in JSS' CryptoManager versions after 4.4.6, 4.5.3, 4.6.0, where it implicitly trusted the root certificate of a certificate chain. Applications using this policy may not properly verify the chain and could be vulnerable to...
CVE-2019-17592
PUBLISHED: 2019-10-14
The csv-parse module before 4.4.6 for Node.js is vulnerable to Regular Expression Denial of Service. The __isInt() function contains a malformed regular expression that processes large crafted input very slowly. This is triggered when using the cast option.